KX Community

Find answers, ask questions, and connect with our KX Community around the world.
KX Community Guidelines

Home Forums KX Academy Advanced Capstone 1.1

  • Advanced Capstone 1.1

    Posted by anduhau on October 26, 2023 at 12:00 am

    I have a question regarding the renaming of the table using the dbmaint.q function… I believe my error is about the database directory, but I cannot figure it out (screenshot attached – the cd command may not play any role, as I am already in the pwd directory, but I am not sure). Moreover, the ls command does not work – should I add the “system” instruction line? I tried the tutorials as well but did not really understand how to access the pwd, ls, cd instructions.

     

    Thank you in anticipation!

     

    anduhau replied 3 months, 1 week ago 2 Members · 2 Replies
  • 2 Replies
  • Laura

    Administrator
    October 27, 2023 at 12:00 am

    Hi  ,

    That error looks like renamecol isn’t defined in your workspace. Have you loaded the dbmaint.q script?

    To check, you can run simply

    renamecol

    it should return the definition of the function if dbmaint.q has been loaded.

    If it throws the same error as your screenshot, the script has not been loaded, and you’ll need to go back to  1.1 and re-read the hint.

    Hope this helps,

    Laura

  • anduhau

    Member
    October 27, 2023 at 12:00 am

    Thank you a lot!!! This fixed my issue.

Log in to reply.