KX Community

Find answers, ask questions, and connect with our KX Community around the world.
KX Community Guidelines

Home Forums KX Solutions KX Control – ds_jemail_a not starting – empty trustAnchors parameter

  • KX Control – ds_jemail_a not starting – empty trustAnchors parameter

    Posted by Laura on September 9, 2021 at 12:00 am

    Hi everyone,

    We are currently having an issue with the ds_email_a process – it refuses to startup and returns:

    2021-09-09 06:47:28,092 [DeltaCConnectorThread DeltaC CC[dev.pointnext.hpe.urbanpul.se:2001:kxemail:************]-170-thread-1] WARN com.fd.delta.q.impl.DeltaC:315 – Connect failed [dev.pointnext.hpe.urbanpul.se:2001] (Unexpected error: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty) retry in 2000ms

    This is happening with both java 11 and java 8 (on Ubuntu 20).

    Has anyone, particularly in KX itself, experienced this? We tried to self-fix but no success. Any help would be appreciated.

    Cheers,
    Adriano

     

    Laura replied 2 months, 2 weeks ago 2 Members · 4 Replies
  • 4 Replies
  • leahs

    Member
    September 9, 2021 at 12:00 am

    Hello Adriano,

    Thank you for sharing this with the community.

    We believe this issue might be Tomcat related. Perhaps, there is an issue in platform but initially, we suggest following the deployment steps again for the TLS trustStore for Tomcat. Ensure that no step was missed, as this appears to be a trustStore issue.

    This link should be helpful for you: https://stackoverflow.com/questions/6784463/error-trustanchors-parameter-must-be-non-empty

    Let us know how you get on and from your feedback, we can decide on how to proceed from there.

    Kind regards,

    Leah

  • Laura

    Administrator
    September 10, 2021 at 12:00 am

    Hi Leah,

     

    Thanks for the quick reply. We will try to redeploy today. However, I have a question:

    We install KX with Control on HTTP only mode, but other processes still can run on TLS if required. We were wondering if this might a be a problem as well?

    Cheers,
    Adriano

  • Laura

    Administrator
    September 13, 2021 at 12:00 am

    Hi Adriano,

    I am fairly sure you can have TLS kdb enabled and run tomcat in HTTP, although I haven’t tried it myself.

    Let us know if it works! If not, we’ll get you to run the support scripts: https://code.kx.com/platform/deployment/raising_support_issues/
    and will reach out to the support team for you!

    Thanks,

    Laura

  • Laura

    Administrator
    September 16, 2021 at 12:00 am

    Hello again
    It turns out that

    1) reinstalling KX solved the problem and

    2) we can run Control as HTTP only.

    Unfortunately, though, I could pinpoint what was causing the problem to begin with. Anyways, I will just be happy that the problem is gone!
    Kind regards,
    Adriano

Log in to reply.