KX Community

Find answers, ask questions, and connect with our KX Community around the world.
KX Community Guidelines

Home Forums kdb+ Need help installing pyq

  • Need help installing pyq

    Posted by Laura on June 17, 2021 at 12:00 am

    I am new to KDB+ and q. I want to install it in my google cloud Debian Buster Linux. I have tried many things to install the pyq extension but didnt find a way to install it successfully. Here are specifications and methods I have tried.

    1) uname -m showing x86_64

    2) I have installed KDB+ 64 bit version. By using command q directly in terminal it gives following info.

    gdrive_bckup_2@instance-3:~$ q
    KDB+ 4.0 2021.04.26 Copyright (C) 1993-2021 Kx Systems
    l64/ 8(16)core 16043MB gdrive_bckup_2 instance-3 10.148.0.3 EXPIRE 2022.06.12 vishveshup@gmail.com KOD #4176665

    q)til 10
    0 1 2 3 4 5 6 7 8 9
    q)

    3) using python 3.7

    gdrive_bckup_2@instance-3:~$ python –version
    Python 3.7.3

    4) python version is 64 bit

    gdrive_bckup_2@instance-3:~$ python
    Python 3.7.3 (default, Jan 22 2021, 20:04:44)
    [GCC 8.3.0] on linux
    Type “help”, “copyright”, “credits” or “license” for more information.
    >>> import struct
    >>> print(struct.calcsize(“P”)*8)
    64

    5) I tried to install / update all of three GNU make, gcc and clang.

    6) Then I tried pip3 install pyq in normal terminal with and without sudo (pip install .. gives an error “bash: pip: command not found”, so mostly I am using pip3 install ..). But unsuccessful.

    https://drive.google.com/file/d/1tSnxHIiaid7lDxRaG1_tmRx_7iHTCoUC/view?usp=sharing

     

    7) Then I followed this guide https://code.kx.com/q/interfaces/pyq/install/#installing-into-a-virtual-environment and created virtualenv but didnt worked. I also tried venv but that also not worked.

    https://drive.google.com/file/d/1GVQOw3WhguvVFC2Bryi_gGpoeHrH-WCf/view?usp=sharing

     

    I tried with anaconda and it also not working.

    https://drive.google.com/file/d/1Mub4ffVk7CcVS1XJkh24pFYWnNPwohNv/view?usp=sharing

     

    To help keep the question clear I have attached all output of error in the txt file via google drive & also captured snip of all files and append them into single png file attached here. Kindly check them for more info.

     

    Please guide me how to install pyq in my system. Thank you.

     

    Previously I have posted this by mistake in q-bies section. Please close that post if posted into irrelevant section else close this. Thanks again !

    Laura replied 2 months, 2 weeks ago 2 Members · 1 Reply
  • 1 Reply
  • cmccarthy1

    Member
    September 14, 2021 at 12:00 am

    Hi,

    I don’t know if this is still an issue but, in step 7 your installation indicates that QHOME could not be found? can you run

    export QHOME=/path/to/q/folder

    and see if that fixes the issue?

    All the best,

    Conor

Log in to reply.